Implementing Cisco Network Security (IINS v3.0) (#42)

What is the minimum Cisco IOS version that supports zone-based firewalls?

12.4 (6)T
15.1
15.0
12.1T